AWS EKS Cluster must be on a supported kubernetes version and latest platform version

Tenacity Id

Risk Level

Categories

eks-004

3

Last Updated:

April 21, 2022

Each Kubernetes minor version has one or more associated Amazon EKS platform versions. Amazon EKS releases new platform versions periodically to enable new Kubernetes control plane settings and to provide security fixes.All deployments must meet the minimum supported version requirements defined within the 'parameters' below. It is recommended to stay one version behind the latest major release at all times.